Klaus Demo klaus / 79b4ccb
Version 0.4.2 -- fixes #83 Jonas Haag 6 years ago
3 changed file(s) with 10 addition(s) and 6 deletion(s). Raw diff Collapse all Expand all
00 Changelog
11 =========
22
3 0.4.2 (Jan 21, 2014)
4 --------------------
5 * Bug #83: Wrong version of Dulwich dependency in ``setup.py``
6
37 0.4.1 (Jan 17, 2014)
48 --------------------
5 * Bug #62: Include ``contrib/*`` in the distribution as ``klaus.contrib.*``.
9 * Bug #82: Include ``contrib/*`` in the distribution as ``klaus.contrib.*``.
610
711 0.4 (Jan 16, 2014)
812 ------------------
55 from klaus.repo import FancyRepo
66
77
8 KLAUS_VERSION = utils.guess_git_revision() or '0.4.1'
8 KLAUS_VERSION = utils.guess_git_revision() or '0.4.2'
99
1010
1111 class Klaus(flask.Flask):
6060
6161 def make_app(repos, site_name, use_smarthttp=False, htdigest_file=None):
6262 """
63 Returns a WSGI with all the features (smarthttp, authentication) already
64 patched in.
63 Returns a WSGI app with all the features (smarthttp, authentication)
64 already patched in.
6565 """
6666 app = Klaus(
6767 repos,
1414
1515 install_data_files_hack()
1616
17 requires = ['flask', 'pygments', 'dulwich>=0.8.6', 'httpauth', 'humanize']
17 requires = ['flask', 'pygments', 'dulwich>=0.9.1', 'httpauth', 'humanize']
1818
1919 try:
2020 import argparse # not available for Python 2.6
2424
2525 setup(
2626 name='klaus',
27 version='0.4.1',
27 version='0.4.2',
2828 author='Jonas Haag',
2929 author_email='jonas@lophus.org',
3030 packages=['klaus', 'klaus.contrib'],